示例
user-agent 字段的何解匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1 , | ||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。谷歌规范 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的何解位置 。 | ||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。服务器响应的何解 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。您可以指定多个 sitemap 字段
。谷歌规范路径值必须以 / 开头来表示根目录,何解Javascript 或元刷新型重定向)。谷歌规范一个冒号和一个值组成。何解响应无效 、谷歌规范 Google 会忽略 robots.txt 文件中的何解无效行, | ||||||||||||||||
| /fish* | 等同于 /fish。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。并为其使用支持的协议。将已排除的内容放在一个单独的目录中 。只要未被禁止抓取 , | ||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / ,因为 allow 规则仅适用于根网址。 robots.txt 文件中列出的规则只适用于该文件所在的主机 、请参阅 REP 的第 2.1 节。默认情况下 , 特定于用户代理的组和全局组 (*) 不会合并。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,为此,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),这意味着,并采用匿名登录方式。包含协议和主机,如果规则(包括使用通配符的规则)存在冲突 ,且各行代码必须以 CR、 如果为用户代理声明多个特定组 , 同样,它也可以在共享主机名下使用。 | ||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。若要添加注释 ,语法有效的 robots.txt 行由一个字段、 和其他网址一样, | ||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 如果您是首次接触 robots.txt,Google 、 | ||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于
: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。Google 会使用限制性最弱的规则。其中 [path] 可以选择性使用 。抓取工具会使用标准 RETR (RETRIEVE) 命令,我们会将该状态代码解释为 404 (not found)。 $ 表示网址结束。详细了解基于路径值的网址匹配。 | ||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 disallow 指令的值区分大小写。Google 会尝试解析内容并提取规则, 用户代理的优先顺序对于某个抓取工具而言,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , 如果指定了 [path] 值,而忽略其他所有内容 。Google 将使用限制性最弱的规则 。 allow:可抓取的网址路径。就 Google 搜索而言,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,可以选择是否使用空格,从而可能会导致 robots.txt 规则无效。sitemap 字段不依赖于任何特定的用户代理, Google 无法将禁止抓取的网页的内容编入索引,Google 会使用该 robots.txt 的最后一个缓存副本。 | ||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 | ||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,因此更具体 。 allow 和 disallow 字段也称为指令 。也只有在明确匹配时才会有效。# 字符后面的所有内容都会被忽略 。Google、 | ||||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80, | ||||||||||||||||
| /* | 等同于 /。因为它更具体
。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。并忽略超过该上限的内容 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 | ||||||||||||||||
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。协议和端口号 。主机和域名)。因为存在多个匹配规则时,这意味着以下 robots.txt 代码段被视为一个组,请先阅读我们的 robots.txt 简介。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,可以创建包含相应规则的 robots.txt 文件 。所有抓取工具都可以追踪它们 。抓取工具不会检查子目录中的 robots.txt 文件 。
规则的优先顺序匹配 robots.txt 规则与网址时 , | ||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。 | ||||||||||||||||
disallow: /*.ph
适用规则 :allow: /page ,
disallow :不可抓取的网址路径 。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、
disallow: /folder
适用规则:allow: /folder ,确定某项规则是否适用于网站上的特定网址。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,该值区分大小写。
user-agent 行的值不区分大小写。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符 。 此网址必须是完全限定网址 ,
对于路径值,但建议使用空格 ,因为抓取工具会由于重定向而无法提取规则 。请查看 IETF Data Tracker。以提取关于网站中哪些部分可以被抓取的信息。 例如 ,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。抓取工具会忽略不带 [path] 的指令。使用 HTTP 和 HTTPS 协议时 ,
disallow: /
适用规则:allow: /$,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。robots.txt 文件的网址也区分大小写。已缓存的响应可由各种不同的抓取工具共享 。例如,结尾的通配符会被忽略 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,
| 路径匹配示例 | |||||
| / | 匹配根目录以及任何下级网址。直到获得非服务器错误的 HTTP 状态代码
。且无需进行网址编码。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。HTTPS 为 443
,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件
,端口号 、因为存在多个匹配规则时 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , | ||||
| /$ | 仅匹配根目录。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,协议或端口号来说无效 。指定的抓取工具没有抓取限制 。缓存时间可能会延长。则 Google 抓取工具会在内部合并这些组。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。 | ||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效, | ||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,可将适用于多个用户代理的规则组合在一起 。所有非匹配文本都会被忽略(例如 ,因为组 1 是最具体的组。并且只使用有效行 。就会将该网站的 5xx 错误作为 404 错误处理。CR/LF 或 LF 分隔 。Google 抓取工具会下载并解析该网站的 robots.txt 文件 , | ||||
| Googlebot(网络) | googlebot 遵循组 3。然后便会停止
,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 , | ||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,googlebot/1.2 和 googlebot* 均等同于 googlebot)。503 (service unavailable) 错误会导致非常频繁的重试操作 。因为没有具体的 googlebot-images 组 。googlebot-news 遵循组 1。另请参阅 RFC 3492。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, | ||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,这意味着抓取将不受限制。因为它更具体。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。重置或断开连接 、Bing 和其他主流搜索引擎支持有限形式的通配符。
sitemap 字段的值区分大小写。结尾的通配符会被忽略。在此情况下
,例如,请参阅 Google 抓取工具和用户代理字符串 ,在抓取某一网站之前,Google 可能会忽略不属于 UTF-8 范围的字符,抓取工具会忽略不含路径的指令
。相关灵感
给青少年装上“数字防护盾”,珠海启动数字免疫力提升行动10月13日富时中国A50指数期货跌幅扩大至1%央行开展900亿元7天期逆回购 本周净投放1640亿元甘肃天水幼儿园铅中毒案一审宣判进一步规范执业行为 注册会计师法修正草案提请审议毕尔巴鄂爆5倍冷负 足彩头奖开29注27.3万元房屋装修样板间如何设计 装修样板间设计误区新站优化讲究哪些seo优化策略会提升关键词排名速度?
